Properly install GTK+ theme depending on version

Authored by lbeltrame on Jun 5 2016, 1:46 PM.

Description

Properly install GTK+ theme depending on version

Currently, even if the theme was updated, CMakeLists.txt would still
pick data from an old "gtk-3.0" directory, instead of the newer
"gtk-3.18" (for GTK+ <= 3.18) or "gtk-3.20" (for GTK+ 3.20 or newer).

This patch fixes it by setting a runtime option ("-DWITH_GTK3_VERSION")
which is set to 3.18 as default (same behavior as before). If one sets
-DWITH_GTK3_VERSION=3.20 or anything higher, CMake will install the
GTK+ 3.20 version.

Thus, (fellow) packagers, bear this in mind: the next version of Plasma
(5.7) will require -DGTK3_VERSION=3.20 added to your CMake setup command
if you use GTK+ 3.20, otherwise, nothing will be needed.

Both Breeze and Breeze-Dark have been adjusted for this.

This was done as opposed to having a version check to not require the
GTK+3 development package just to check the version.

CCMAIL: plasma-devel@kde.org
CCMAIL: kde-distro-packagers@kde.org

Details

Committed
lbeltrameJun 5 2016, 1:46 PM
Parents
R98:499226afa44c: Update for GTK 3.20
Branches
Unknown
Tags
Unknown
dirrukd added a subscriber: dirrukd.Jun 5 2016, 2:23 PM

The assets directory should also be installed otherwise the theme won't work properly

Added as of 4fcde887a817e948c1605d42091ca11504367f43.

But seriously, why didn't this come up in the initial review? Like the libtaskmanager patch, did anyone try to actually build and install what is being reviewed, aside checking the code?

Yes, a bit ticked off, even though it's my fault originally in this specific revision, and I fully acknowledge that.