Diffusion Clazy 83d6fe02203e

Require the new policy CMP0074

Authored by nkosjar on Fri, Sep 20, 10:21 AM.

Description

Require the new policy CMP0074

Configuring with cmake 3.12 emits the following warning and ignores LLVM_ROOT:

CMake Warning (dev) at cmake/FindClang.cmake:46 (find_package):

Policy CMP0074 is not set: find_package uses <PackageName>_ROOT variables.
Run "cmake --help-policy CMP0074" for policy details.  Use the cmake_policy
command to set the policy and suppress this warning.

CMake variable LLVM_ROOT is set to:

  /d2/llvm/9/vanilla/installs/Release

For compatibility, CMake is ignoring the variable.

Call Stack (most recent call first):

CMakeLists.txt:26 (find_package)

This warning is for project developers. Use -Wno-dev to suppress it.

Details

Committed
smartinsFri, Sep 20, 10:26 AM
Parents
R74:902da94ed32e: Fix linking against llvm/clang 9.0
Branches
Unknown
Tags
Unknown