Fix Python 3 warning

Authored by Nate Graham <pointedstick@zoho.com> on Dec 24 2018, 3:02 AM.

Description

Fix Python 3 warning

Summary:
This tool currently prints a warning when run with Python 3:

./list_dependencies:147: FutureWarning: Possible nested set at position 9
  result = re.search('(^[^[]*)[[](.*)]$', item)

This patch fixes the issue.

Test Plan:
No more warnings on Python 3 and still works
Still works just fine with Python 2

Reviewers: mpyne, apol

Reviewed By: mpyne

Differential Revision: https://phabricator.kde.org/D17771

Details

Committed
Nate Graham <pointedstick@zoho.com>Dec 26 2018, 12:24 AM
Reviewer
mpyne
Differential Revision
D17771: Fix Python 3 warning
Parents
R499:9a6707299b78: gcompris, stable is now 0.95
Branches
Unknown
Tags
Unknown
Nate Graham <pointedstick@zoho.com> committed R499:0855447437d5: Fix Python 3 warning (authored by Nate Graham <pointedstick@zoho.com>).Dec 26 2018, 12:24 AM