Merge remote-tracking branch 'origin/5.0'

Authored by kfunk on Sep 7 2016, 7:58 AM.

Description

Merge remote-tracking branch 'origin/5.0'

Merged Changes

CommitAuthorDetailsCommitted
bbb9dccb4bd0kfunk
Minor optimization: store in temp variable 
Sep 7 2016
9d73ce1523b7kfunk
Fix PluginController::isEnabled 
Sep 7 2016
c0e4c85f1d45kfunk
WelcomePage: Prettify StandardPage 
Sep 7 2016
3be78943ead9mwolff
Optimize QHash usage for topcontext refcounting in the DUChain 
Sep 6 2016
e1ff9fd724e7mwolff
Use range-based-for here now. 
Sep 6 2016
7a05e2313194mwolff
Make const explicit here, it was implicitly const before though 
Sep 6 2016
8c46e8e76585mwolff
Release the background parser lock while creating parse jobs. 
Sep 6 2016
dedcb931355cmwolff
Separate finding the next document to parse and creating a job for it. 
Sep 6 2016
7e8af89e7d70mwolff
Cleanup the code structure even further. 
Sep 6 2016
b993c09128e0mwolff
Hoist checks out of loops. 
Sep 6 2016
6c03e7f01041mwolff
Hoist code snippet out into its own little method 
Sep 6 2016
ad9622923b91mwolff
Further simplify the code now that we really only handle a single job. 
Sep 6 2016
338dd63aa806mwolff
Remove dead code 
Sep 6 2016
1e7327a49983mwolff
Cleanup code to explicitly mark we stop the loop after the first job. 
Sep 6 2016
af242fe3ea11mwolff
Don't reference destroyed data in lambda run in background thread. 
Sep 6 2016
c4cf0fa8859dmwolff
Introduce priority and documentsForPriority locals for better readability 
Sep 6 2016
ee7ad7a29086mwolff
Simplify code, move setting of setSequentialProcessingFlags to createParseJob 
Sep 6 2016
54506df4eb5dmwolff
Cleanup code, mostly minor stuff and moving stuff around a bit. 
Sep 6 2016
e01f566f9012mwolff
Revert "Refactor the code a bit to make it more readable and clean." 
Sep 6 2016
a80725bfecc9mwolff
Revert "Document apparently broken m_maxParseJobs increment" 
Sep 6 2016
9a87cb43e554kfunk
vcs: Drop FlexiableAction in favor of lambda usage 
Sep 6 2016
8d5dab8ba9bcmwolff
Document apparently broken m_maxParseJobs increment 
Sep 6 2016
78420f588cc0mwolff
Refactor the code a bit to make it more readable and clean. 
Sep 6 2016
c18e38d72497mwolff
Refactor: introduce url local to make code a bit more readable. 
Sep 6 2016
64f72d3fad28mwolff
Add test to trigger deadlock in BackgroundParser. 
Sep 6 2016
f0c7aa821f74kfunk
VcsEventWidget: Select first row after population 
Sep 5 2016
03cec281b5d6kfunk
Use official Git logo for Git plugin 
Sep 5 2016
b30d508d2d76kfunk
LaunchConfigurationDialog: Don't allow to collapse 
Sep 5 2016