In D6291 a small naming mistake led to Wayland session with logind not working anymore. Patch to make it work again.
- Group Reviewers
- R108:a49ba5054f81: [logind] Correct property name to fix logind session
Yea, thought about it. It was probably called s_login1ActivateProperty for now because in the ConsoleKit case it has the value "activate".
But IMO calling it s_login1ActiveProperty as you proposed would make more sense because the variable/value describes a status. I can change it if others (@erickoegel?) think the same. Either with this diff or in a seperate one.
Oh wow, yes the property for logind is "Active" and in ConsoleKit2 "active". My brain must have gone out to lunch there when cleaning up the diff to submit it. So s_login1ActiveProperty/s_ck2ActiveProperty makes sense. Sorry about that.