Find minimum required Breeze version instead of current version
ClosedPublic

Authored by graesslin on Feb 17 2017, 6:13 AM.

Details

Summary

So far KWin put a version requirement on Breeze which is the current
version number of KWin. This is technically correct, but distributions
seem to have problems with it. E.g. I noticed twice in Debian testing
that kwin defaults to Plastik which happens when Breeze is not found.
I reported it, it got fixed, now it's again broken.

Thus I think that distributions have problems with the requirement of
building Breeze prior to KWin. As KWin does not depend on the minor
version, let's depend only on the actual required version, which is
5.8 in the 5.8 branch, 5.9 in the 5.9 branch and master.

Diff Detail

Repository
R108 KWin
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
graesslin retitled this revision from to Find minimum required Breeze version instead of current version.Feb 17 2017, 6:13 AM
graesslin updated this object.
graesslin edited the test plan for this revision. (Show Details)
graesslin added reviewers: KWin, Plasma.
Restricted Application added a project: KWin. · View Herald TranscriptFeb 17 2017, 6:13 AM
Restricted Application added subscribers: kwin, plasma-devel. · View Herald Transcript
bshah accepted this revision.Feb 17 2017, 11:06 AM
bshah added a reviewer: bshah.
bshah added a subscriber: bshah.

+1

This revision is now accepted and ready to land.Feb 17 2017, 11:06 AM
This revision was automatically updated to reflect the committed changes.