Don't break compatibility with old configs
ClosedPublic

Authored by elvisangelaccio on Feb 13 2017, 10:26 AM.

Details

Summary

Commit 4a06c4d34f doesn't take into account old config files where the
value of the key is 'true', breaking the getter for the warps property.

Test Plan

Add gtk-primary-button-warps-slider=true both in ~/.gtkrc-2.0 and
~/.config/gtk-3.0/settings.ini; open gtk-config kcm, warps checkbox is now checked
as expected.

Diff Detail

Repository
R99 KDE Gtk Configuration Tool
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
elvisangelaccio retitled this revision from to Don't break compatibility with old configs.Feb 13 2017, 10:26 AM
elvisangelaccio updated this object.
elvisangelaccio edited the test plan for this revision. (Show Details)
elvisangelaccio added a reviewer: apol.
Restricted Application added a project: Plasma. · View Herald TranscriptFeb 13 2017, 10:26 AM
Restricted Application added a subscriber: plasma-devel. · View Herald Transcript
broulik accepted this revision.Feb 13 2017, 12:10 PM
broulik added a reviewer: broulik.
This revision is now accepted and ready to land.Feb 13 2017, 12:10 PM
This revision was automatically updated to reflect the committed changes.