Rename checkForDecorators() to docstringTypeOverride(), because it doesn't do anything involving decorators. (!)
Move the code choosing between class and function types to visitCall(), because it's nothing to do with docstring contents and made the different code paths very hard to follow.
Make it return the type it produces, rather than calling encounter() itself, for clarity.
Use the new isAlias argument of functionForCalled instead of some code to do the same thing.