Relicense some files to LGPLv2+ or v2v3, OK by all contributors according to relicensecheck.pl
ClosedPublic

Authored by dfaure on Dec 14 2019, 12:04 AM.

Details

Summary

Unfortunately this doesn't cover all LGPLv2-only files.
I cannot find a way to contact Bernhard Loos
(and didn't get a reply from Martijn Klingens)

NO_CHANGELOG

Test Plan

Builds

Diff Detail

Repository
R309 KService
Branch
relicense
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 19830
Build 19848: arc lint + arc unit
dfaure created this revision.Dec 14 2019, 12:04 AM
Restricted Application added a project: Frameworks. · View Herald TranscriptDec 14 2019, 12:04 AM
Restricted Application added a subscriber: kde-frameworks-devel. · View Herald Transcript
dfaure requested review of this revision.Dec 14 2019, 12:04 AM

Note that you don't have a LGPL-2.0-or-later COPYING file in this repo (there's also no LGPL-2.0-only).

COPYING.LIB contains the LGPL-2.1 license which is used by one file in the tests/ folder

dfaure updated this revision to Diff 71499.Dec 14 2019, 10:51 AM

Add COPYING.LGPL-2 and COPYING.LGPL-3

Indeed, I never think about those COPYING files. In fact this is something that is definitely inconsistent in most of the frameworks right now...

cgiboudeaux added inline comments.Dec 14 2019, 11:05 AM
src/services/kservicefactory.cpp
4–9

What's the reason for only changing this one to LGPL2 only or LGPL3 only (without the eV clause)?

dfaure added inline comments.Dec 14 2019, 11:12 AM
src/services/kservicefactory.cpp
4–9

The reason is Waldo Bastian, who agreed to 2-or-3 but not to 2+

waba (  17 LOC): 7ee6ea605e,ec1dc9339f,307504885e,764b51a72c,f1d9d663e6,010677452e,79787d4962,5dcce58a32,0ef36944f8

He did agree to +eV, but others didn't (lunakl, mueller).
Hmm, on further investigation, the commits from those two were all trivial (typos, includes, fsf address in license header). I'll make it 2-or-3-with-eV-clause then.

I guess this can then be turned into 2+ by asking the eV, but is that worth the trouble?
All this is moot without Bernhard Loos anyway.

dfaure updated this revision to Diff 71501.Dec 14 2019, 11:13 AM

Make kservicefactory.cpp 2-or-3-with-eV-clause

cgiboudeaux accepted this revision.Dec 14 2019, 11:37 AM
This revision is now accepted and ready to land.Dec 14 2019, 11:37 AM
dfaure closed this revision.Dec 14 2019, 11:44 AM
cgiboudeaux added inline comments.Dec 14 2019, 11:46 AM
src/services/kservicefactory.cpp
4–9

I guess this can then be turned into 2+ by asking the eV, but is that worth the trouble?

Nope, The e.V. can't turn 2.0-only to 2.0-or-later. The proxy is only allowed to act on future versions of the license

I see, thanks for the clarification.