CMake: Bump CMake minimum version to 3.5

Authored by akulichalexandr on Sep 19 2019, 11:31 PM.

Diff Detail

R476 Telepathy Logger Qt bindings
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.
akulichalexandr requested review of this revision.Sep 19 2019, 11:31 PM
akulichalexandr created this revision.

Do we have any reason to stick to 2.8.12?
Is there any single user or developer who need a new TelepathyQtLogger but can't update CMake at least to 3.5?
CMake 3.5 is available since Ubuntu 16.04. I think it is old enough to be required.

akulichalexandr edited the summary of this revision. (Show Details)Sep 19 2019, 11:33 PM
heikobecker accepted this revision.Sep 24 2019, 6:43 AM

I don't think so and Frameworks also need 3.5 since quite some time.

This revision is now accepted and ready to land.Sep 24 2019, 6:43 AM
This revision was automatically updated to reflect the committed changes.