Fix build with cmake < 3.12
ClosedPublic

Authored by wbauer on Tue, Sep 10, 10:19 AM.

Details

Summary

add_compile_definitions() was introduced in cmake 3.12.
As the specified minimum cmake version is 2.8.12, use the older add_definitions() instead.

Test Plan

Builds fine now with cmake 3.10.2, before I got this error message:

CMake Error at CMakeLists.txt:10 (add_compile_definitions):
  Unknown CMake command "add_compile_definitions".

Still builds fine with cmake 3.15.1.

According to the build log, -DQURL_NO_CAST_FROM_STRING is still passed to the compiler as before.

Diff Detail

Repository
R443 KImageMapEditor
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
wbauer requested review of this revision.Tue, Sep 10, 10:19 AM
wbauer created this revision.
aacid accepted this revision.Tue, Sep 10, 12:49 PM
This revision is now accepted and ready to land.Tue, Sep 10, 12:49 PM
This revision was automatically updated to reflect the committed changes.