[KSieve] Fix messagebox about connection to server lost
ClosedPublic

Authored by dfaure on Tue, Sep 10, 8:51 AM.

Details

Summary

If the TCP idle timeout kicks in, or we time out trying to connect,
and the user isn't manually doing something sieve related (no job),
this isn't worth bothering the user about.

This typically happens some time after starting kmail, for the initial
vacation check.

The 2019 Akademy university network was the ideal testcase for this
(due to blocked ports) but I also regularly get this elsewhere.

Test Plan

start kmail, wait. There is no longer two annoying messageboxes
popping up (two because we have two sieve sessions at all times).

The lack of the word Sieve in the messageboxes made this even more irritating
(they were completely out of context) but that's for master (i18n change).

Diff Detail

Repository
R91 PIM: Sieve Handling Library
Branch
Applications/19.08
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 16306
Build 16324: arc lint + arc unit
dfaure created this revision.Tue, Sep 10, 8:51 AM
Restricted Application added a project: KDE PIM. · View Herald TranscriptTue, Sep 10, 8:51 AM
Restricted Application added a subscriber: kde-pim. · View Herald Transcript
dfaure requested review of this revision.Tue, Sep 10, 8:51 AM
ervin accepted this revision.Tue, Sep 10, 9:04 AM

Looks good to me. Glad the network here is not great, that helped finally nailing that one down. :-)

This revision is now accepted and ready to land.Tue, Sep 10, 9:04 AM
lbeltrame accepted this revision.Tue, Sep 10, 9:28 AM
lbeltrame added a subscriber: lbeltrame.

Looks ok to me.

dfaure closed this revision.Tue, Sep 10, 10:37 AM