[webenginepart] Fix build with cmake < 3.7

Authored by wbauer on Aug 7 2019, 4:35 PM.



VERSION_GREATER_EQUAL was introduced in cmake 3.7, but the specified minimum version is 3.0.
So use NOT VERSION_LESS instead to still support older cmake versions too.

Test Plan

Builds fine with cmake 3.5.2 now, and also newer versions.
The corresponding definitions are still passed to gcc when building with QtWebEngine 5.13 (haven't tried older versions), according to the build output.

Before, I got this error when using cmake 3.5.2:

CMake Error at webenginepart/src/CMakeLists.txt:30 (if):
  if given arguments:

    "Qt5WebEngineWidgets_VERSION" "VERSION_GREATER_EQUAL" "5.12.0"

  Unknown arguments specified

Diff Detail

R226 Konqueror
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.
wbauer requested review of this revision.Aug 7 2019, 4:35 PM
wbauer created this revision.
aacid accepted this revision.Aug 7 2019, 5:04 PM
This revision is now accepted and ready to land.Aug 7 2019, 5:04 PM
This revision was automatically updated to reflect the committed changes.