HypothesisTest View and Dock
ClosedPublic

Authored by devanshuagarwal on Jun 11 2019, 4:19 PM.

Details

Reviewers
sgerlach
asemke
Summary

Update diff for revision: https://phabricator.kde.org/D21684

Diff Detail

Repository
R262 LabPlot
Lint
Lint Skipped
Unit
Unit Tests Skipped
Restricted Application added a project: KDE Edu. · View Herald TranscriptJun 11 2019, 4:19 PM
Restricted Application added a subscriber: kde-edu. · View Herald Transcript
devanshuagarwal requested review of this revision.Jun 11 2019, 4:19 PM
sgerlach added inline comments.Jun 11 2019, 6:46 PM
src/backend/hypothesis_test/HypothesisTest.cpp
186 ↗(On Diff #59605)

QString::isEmpty()

221 ↗(On Diff #59605)

"At least"

229 ↗(On Diff #59605)

readable error codes would be more convenient.

244 ↗(On Diff #59605)

please indent to make it easier to read.

250 ↗(On Diff #59605)

"t_value" would be clearer

255 ↗(On Diff #59605)

why 9? please comment.

280 ↗(On Diff #59605)

UTF8_QSTRING()?

326 ↗(On Diff #59605)

why 8?

440 ↗(On Diff #59605)

switch (test is an enum)

442 ↗(On Diff #59605)

t_value?

608 ↗(On Diff #59605)

better use "switch"?

618 ↗(On Diff #59605)

double t = ...

619 ↗(On Diff #59605)

double df = ..

746 ↗(On Diff #59605)

cell1 and cell2 would be more specific.

812 ↗(On Diff #59605)

how about returning an error code instead of using n[0] for errors?

860 ↗(On Diff #59605)

not "-2"?

866 ↗(On Diff #59605)

QString::isEmpty()

880 ↗(On Diff #59605)

you can omit braces in one-liners.

900 ↗(On Diff #59605)

Maybe better define constant string in the header?

src/backend/hypothesis_test/HypothesisTestPrivate.h
81 ↗(On Diff #59605)

order of parameter is different compared to other findStats-functions.

src/kdefrontend/dockwidgets/HypothesisTestDock.cpp
87 ↗(On Diff #59605)

still not camelCase :-)

517 ↗(On Diff #59605)

translation

525 ↗(On Diff #59605)

translation

528 ↗(On Diff #59605)

translation

src/kdefrontend/dockwidgets/HypothesisTestDock.h
72 ↗(On Diff #59605)

why not use a single variable of type testType?

74 ↗(On Diff #59605)

better use an enum for different kinds of test?

src/kdefrontend/hypothesis_test/HypothesisTestView.cpp
68 ↗(On Diff #59605)

please define extra variable for font size

devanshuagarwal marked 17 inline comments as done.
  1. changed Summary Result TreeView/model to list of QLabels.
  1. Added more helper functions
  1. Used Error Codes
  1. Used Switch for enums
  1. And tried to do some more changes according to previous comments.
sgerlach accepted this revision.Jun 13 2019, 8:20 AM

looks good so far. We can refactor or simplify later. Please commit.

This revision is now accepted and ready to land.Jun 13 2019, 8:20 AM
sgerlach closed this revision.Jul 14 2019, 7:10 AM