Fix missings override warnings
ClosedPublic

Authored by meven on Mar 22 2019, 11:41 AM.

Details

Reviewers
sitter
Group Reviewers
Restricted Owners Package(Owns No Changed Paths)
Commits
R487:f7575f8befb7: Fix missings override warnings

Diff Detail

Repository
R487 Phonon
Branch
fix-warnings
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 9974
Build 9992: arc lint + arc unit
meven created this revision.Mar 22 2019, 11:41 AM
Owners added a reviewer: Restricted Owners Package.Mar 22 2019, 11:41 AM
meven requested review of this revision.Mar 22 2019, 11:41 AM
meven retitled this revision from Fix overrid warning and add two Q_FALLTHROUGH to Fix missings override warnings and two Q_FALLTHROUGH warnings.Mar 22 2019, 11:42 AM
sitter requested changes to this revision.Mar 22 2019, 12:15 PM
sitter added a subscriber: sitter.

Q_FALLTHROUGH is too new. This thing is still qt 4 compatible

This revision now requires changes to proceed.Mar 22 2019, 12:15 PM
meven updated this revision to Diff 54551.Mar 22 2019, 12:36 PM

Removing the Q_FALLTHROUGH

meven retitled this revision from Fix missings override warnings and two Q_FALLTHROUGH warnings to Fix missings override warnings.Mar 22 2019, 12:36 PM

Q_FALLTHROUGH is too new. This thing is still qt 4 compatible

I am a bit surprised, latest Qt 4 was released 8 years ago.
But that's ok, I guess some project still need this.

sitter accepted this revision.Mar 22 2019, 1:45 PM

Software that hasn't been ported by now IMO deserves no further fixes anyway. At this point it's more a matter of anyone finding the time and energy to actually rip Qt4 out and moving to ECM :/

Change looks good to me though.

This revision is now accepted and ready to land.Mar 22 2019, 1:45 PM
This revision was automatically updated to reflect the committed changes.