make global menu minimize state aware
AbandonedPublic

Authored by mvourlakos on Nov 6 2018, 6:25 PM.

Details

Reviewers
broulik
davidedmundson
Group Reviewers
Plasma
Summary

--a new menuIsHidden property is added in the
AppMenuModel in order to inform model consumers
when the menu should be shown or not

BUG: 395853

Test Plan
  • check that current menu behavior still works
  • check that when the active window is minimized and there is no other active window the menu is not shown

Diff Detail

Repository
R120 Plasma Workspace
Branch
appMenuMinimize
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 4902
Build 4920: arc lint + arc unit
mvourlakos created this revision.Nov 6 2018, 6:25 PM
Restricted Application added a project: Plasma. · View Herald TranscriptNov 6 2018, 6:25 PM
Restricted Application added a subscriber: plasma-devel. · View Herald Transcript
mvourlakos requested review of this revision.Nov 6 2018, 6:25 PM
anthonyfieroni added inline comments.
applets/appmenu/plugin/appmenumodel.cpp
244–247

setMenuHidden(info.isMinimized());

applets/appmenu/plugin/appmenumodel.h
42

Naming should be menuHidden, setMenuHidden if we follow rules.

mvourlakos updated this revision to Diff 44985.Nov 6 2018, 8:42 PM
  • fix naming and improve code
mvourlakos updated this revision to Diff 44987.Nov 6 2018, 8:44 PM
  • remove whitespace
mvourlakos marked 2 inline comments as done.Nov 6 2018, 8:45 PM
mvourlakos edited the test plan for this revision. (Show Details)
apol added a subscriber: apol.Nov 7 2018, 12:07 AM
apol added inline comments.
applets/appmenu/package/contents/ui/main.qml
107

use null

mvourlakos updated this revision to Diff 44998.Nov 7 2018, 1:11 AM
  • use null in qml side
mvourlakos marked an inline comment as done.Nov 7 2018, 1:12 AM
trmdi added a subscriber: trmdi.Nov 7 2018, 4:00 AM
mvourlakos updated this revision to Diff 45141.Nov 8 2018, 10:38 PM
This comment was removed by mvourlakos.
mvourlakos updated this revision to Diff 45142.Nov 8 2018, 10:39 PM
This comment was removed by mvourlakos.
mart added a subscriber: mart.Nov 12 2018, 10:33 AM
mart added inline comments.
applets/appmenu/plugin/appmenumodel.h
62

maybe the opposite looks more consistent with usual Qt api,
just a bool visible

mvourlakos added inline comments.Nov 12 2018, 3:55 PM
applets/appmenu/plugin/appmenumodel.h
62

no problem, so do we have an agreement to rename menuHidden -> visible?

  • rename menuHidden to visible
mvourlakos marked an inline comment as done.Nov 13 2018, 12:06 PM

follow mart suggestion

included in D16768 and I will upload a new patch to rename menuHidden -> visible as @mart requested

mvourlakos abandoned this revision.Nov 22 2018, 6:54 PM